Crash in next build -> Error: Cannot find module 'ajv/lib/compile/equal'

alerg
0
alerg
commented 13 days ago

"next": "7.0.2"
----"webpack": "4.20.2"
--------"webpackbar": "2.6.3"
------------"table": "4.0.3"

The dependency "table" that has "webpackbar" installs dependencies with the prefix ^. One of its dependencies removed code that caused the next build process to be broken:

Error: Cannot find module 'ajv/lib/compile/equal'
at Function.Module.resolveFilename (module.js:547:15) at Function.Module.load (module.js:474:25)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/nodemodules/table/dist/validateConfig.js:2:13) at Module.compile (module.js:652:30)
at Object.Module.extensions..js (module.js:663:10) at Module.load (module.js:565:32) at tryModuleLoad (module.js:505:12) at Function.Module.load (module.js:497:3)

0
Informations
Question โ€ข Unresolved
#c28 - Created 13 days ago