Nuxtent breaks with @nuxtjs/axios versions higher than 4.5.2

template01
3
template01
commented 8 months ago

When using a version of @nuxtjs/axios versions higher than 4.5.2 for example version 5.0.0 my get requests breaks with.

Error: Request failed with status code 404

Anyone with the same problem?

Cheers

1
dhavalwd
5
dhavalwd
commented 8 months ago

Yes, facing same problem. Downgrading axios to 4.5.2 and setting browserBaseURL to live site URL solves the issue for now.

1
derevandal
50
derevandal
commented 8 months ago

@template01 could you tell us what route your axios tried request? is this error happen in dev ou prod mode?

I tested here with nuxt 1.4, nuxtent 1.4.1 and nuxtjs/axios 5.3.1 and I got no errors.
Screenshot_8.png

0
brandonpittman
0
brandonpittman
commented 22 days ago

Have the same issue, but only if I register axios as a module in nuxt.config.js.

0
Informations
Question โ€ข Unresolved
#c124 - Created 8 months ago