Vue packages version mismatch

markhaehnel
0
markhaehnel
commented 3 years ago

I get the following error while using alpha.4 of nuxt:

[..]\node_modules\vue-server-renderer\index.js:8
  throw new Error(
  ^

Error:

Vue packages version mismatch:
- vue@2.4.1
- vue-server-renderer@2.3.4
This may cause things to work incorrectly. Make sure to use the same version for both.
0
pi0
37.3k
pi0
commented 3 years ago

Hey @markhaehnel . This problem will be fixed soon. For now, please explicitly define dependencies in youe package.json:

"dependencies": {
 "vue": "2.3.4",
 "vue-server-renderer": "2.3.4",
 "vue-template-compiler": "2.3.4",
}
10
gbezyuk
176
gbezyuk
commented 3 years ago

I've just run into the similar issue, badly wanting Vue 2.4.1's $attrs and $listeners for HOC and realizing Nuxt is weirdly still dependant on 2.3.4.
Just changing dependencies in package.json of your project does not help at all to change nuxt's own dependencies. Using npm shrinkwrap with manual changes does, though.

1
dohomi
1.4k
dohomi
commented 3 years ago

@gbezyuk I think that alpha5 was published before NUXT 2.4 came out. @pi0 did you guys plan to release a public version with compatibility of 2.4.x soon? Is it otherwise safe to use the current dev?

0
pi0
37.3k
pi0
commented 3 years ago

@dohomi Actually safest way is to keep using 2.3.4 (and always latest tested version with nuxt) dev is stable too but not heavily tested and documented that's why the release is delayed. Just stay tuned for rc1 :)

0
gbezyuk
176
gbezyuk
commented 3 years ago

Yeah, I know. Safest way, heavily tested. $ATTRS and $LISTENERS, guys!!! )

1
dohomi
1.4k
dohomi
commented 3 years ago

@pi0 thanks! any estimated date for the rc1? Keep up the good work!

0
zhanziyang
0
zhanziyang
commented 3 years ago

Why is this closed? Is it fixed already? Which version of nuxt should we use if we want [email protected] features? Please help. Thank you!!!

0
pi0
37.3k
pi0
commented 3 years ago

@zhanziyang Please use 1.0.0-rc3 witch comes with [email protected]

1
IamManchanda
0
IamManchanda
commented 2 years ago

Happened with v2.5 too
Here I report 2.5

PS: Can't share whole screen/all commands as came in a professional project instead of open source

Have used this comment to correct the same

screen shot 2018-05-17 at 10 45 18 pm

0
gerwinov
0
gerwinov
commented 2 years ago

I can report the exact same behavior as @IamManchanda describes.

0
derekshull
15
derekshull
commented 2 years ago

Getting the same as @gerwinov and @IamManchanda

0
ramstein74
0
ramstein74
commented 2 years ago

after updating nuxtjs to 1.4 .2 i get this when runing dev

Vue packages version mismatch:

0
nusendra
30
nusendra
commented 2 years ago

@ramstein74 same with me.

0
availit
0
availit
commented 2 years ago

I too can report getting the same error as @IamManchanda and @gerwinov
Any idea how to resolve it?

0
nusendra
30
nusendra
commented 2 years ago

after i remove vuenut, the error is gone. So, in my opinion, just uninstall the unused dependencies. Or upgrade it

0
besnikh
0
besnikh
commented 2 years ago

@All is there any solution to this I am getting the same error after upgrading to nuxt 1.4.2

0
galvez
4.5k
galvez
commented 2 years ago

npm i [email protected] -s

On Sat, Aug 11, 2018 at 4:40 PM besnikh notifications@github.com wrote:

@ALL https://github.com/ALL is there any solution to this I am getting
the same error after upgrading to nuxt 1.4.2


You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub
https://github.com/nuxt/nuxt.js/issues/1084#issuecomment-412297332, or mute
the thread
https://github.com/notifications/unsubscribe-auth/AAAwA7eMvqRaAVrwRb5RTgFzpV3w94Nxks5uPzM9gaJpZM4OYF5C
.

0
antony
0
antony
commented 2 years ago

@galvez Surely nuxt should install the latest vue automatically?

I've just upgraded to 1.4.2 and this is still an issue sadly.

0
galvez
4.5k
galvez
commented 2 years ago

It will. Have you rm -rf node_modules before installing everything again?

>

0
zzleomar
0
zzleomar
commented 2 years ago

@ramstein74 Did you solve it?

0
ramstein74
0
ramstein74
commented 2 years ago

Yes , i guess i just changed package.json to have both with the same version
instead of this

make sure to have this

Not the best but it works

2018-08-30 6:29 GMT+01:00 zzleomar notifications@github.com:

@ramstein74 https://github.com/ramstein74 Did you solve it?


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub
https://github.com/nuxt/nuxt.js/issues/1084#issuecomment-417194565, or mute
the thread
https://github.com/notifications/unsubscribe-auth/ABJ56j_mUvEF3_K1k-nyYeb_CMVUkQ_zks5uV3g_gaJpZM4OYF5C
.

0
mariojankovic
0
mariojankovic
commented 2 years ago

Happened to me while upgrading to Nuxt 2.0. Did yarn upgrade, everything works fine now.

0
Informations
QuestionResolved
#c943 - Created 3 years ago