Module build failed buble.js, templateLoader.js, Parser.pp$4.raise

siberiadev
5
siberiadev
commented a year ago

This is not an issue, it's just a big problem, wich I can't resolve by my self. So maybe someone can help me.
When I run dev my nuxt app in ssr mode it give me an error below:

Module build failed (from ./node_modules/vue-loader/lib/loaders/templateLoader.js): SyntaxError: Unexpected token (1:239) at Parser.pp$4.raise (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:2610:13) at Parser.pp.unexpected (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:637:8) at Parser.pp$3.parseParenAndDistinguishExpression (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:2154:49) at Parser.pp$3.parseExprAtom (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:2061:41) at Parser.parseExprAtom (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:4372:24) at Parser.pp$3.parseExprSubscripts (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1955:19) at Parser.pp$3.parseMaybeUnary (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1932:17) at Parser.pp$3.parseExprOps (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1874:19) at Parser.pp$3.parseMaybeConditional (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1857:19) at Parser.pp$3.parseMaybeAssign (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1832:19) at Parser.pp$3.parseMaybeConditional (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1862:28) at Parser.pp$3.parseMaybeAssign (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1832:19) at Parser.pp$3.parseParenAndDistinguishExpression (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:2139:30) at Parser.pp$3.parseExprAtom (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:2061:41) at Parser.parseExprAtom (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:4372:24) at Parser.pp$3.parseExprSubscripts (e:\OSPanel\domains\webfolder\node_modules\vue-template-es2015-compiler\buble.js:1955:19)

It's also says that my problem in node_modules\vue-template-es2015-compiler\buble.js

When I run dev in spa mode all is good.
Can my .webp extension file effect it?

I checked whole google and nothing can help me.

0
siberiadev
5
siberiadev
commented a year ago

What I already done:

  1. Check my all js files for any errors
  2. Rebuild all node_modules
  3. Check google.com for this type of error
0
siberiadev
5
siberiadev
commented a year ago

Comand line says after complete compilation^

√ Client
Compiled successfully in 4.26s

× Server
Compiled with some errors in 4.62s

0
siberiadev
5
siberiadev
commented a year ago

Anyone please

0
hacklover
0
hacklover
commented 18 days ago

It happened just now to me,
I found out it was an empty <template></template> block.

Panic :|

0
Informations
QuestionUnresolved
#c8650 - Created a year ago