Nuxt Edge : adding/handling babel polyfill?

valeriosillari
14
valeriosillari
commented a year ago

I am starting using Nuxt Edge and trying to update a project based on Nuxt 1.4.2.

On Nuxt v1 I've added the babel polyfill for a IE11 compatibility following documentation and info n the forum, and it works.
I've used to install the npm package, and the nuxt config file I added the babel polyfill as vendor.

Now on Nuxt Edge the vendors are gone.
When I run Nuxt, the CLI give me a warning about vendor: "vendor has been deprecated due to webpack4 optimization"

So my question is: how can add on Nuxt Edge Babel Polyfill?

Anyone could give me some tips?
I see articles where people talking about the removal of vendors, but I didn't find anything explaining how to handle the old dependencies using vendor …

thanks :)

2
souljorje
0
souljorje
commented a year ago

As i understand now we don't need to use it, it's already built in.

0
voronianski
0
voronianski
commented 10 months ago

I have the same question. My [email protected] website is not working in IE11.

0
hareku
15
hareku
commented 10 months ago

Me too.
My nuxt2.2 project is not working in safari 9~10.

How do i fix?

0
tarreislam
0
tarreislam
commented 9 months ago

I have the same question. My [email protected] website is not working in IE11.

This should fix that

in nuxt.config.js

head {
 ...
 meta: [
    {'http-equiv': 'X-UA-Compatible', content: 'IE=edge'}
  ]
}
0
Informations
QuestionUnresolved
#c7787 - Created a year ago