Repository nuxt.js

now deployment failing (sh: nuxt: not found)

tchret
5
tchret
commented 8 months ago

image

package.json

{
  "name": "www",
  "version": "1.0.0",
  "description": "personal website",
  "author": "tchret",
  "private": true,
  "scripts": {
    "dev": "nuxt",
    "build": "nuxt build",
    "start": "nuxt start",
    "generate": "nuxt generate",
    "lint": "eslint --ext .js,.vue --ignore-path .gitignore .",
    "precommit": "npm run lint"
  },
  "dependencies": {
    "@nuxtjs/axios": "^5.0.0",
    "@nuxtjs/markdownit": "^1.2.0",
    "emoji-mart-vue": "^2.4.5",
    "lodash": "^4.17.5",
    "nuxt": "^1.0.0",
    "vue-lodash": "^1.0.4",
    "vue-markdown": "^2.2.4",
    "vue-markdown-loader": "^2.4.0"
  },
  "devDependencies": {
    "babel-eslint": "^8.2.1",
    "cross-env": "^5.0.1",
    "eslint": "^4.15.0",
    "eslint-loader": "^1.7.1",
    "eslint-plugin-vue": "^4.0.0",
    "node-sass": "^4.7.2",
    "nuxt-sass-resources-loader": "^1.1.1",
    "sass-loader": "^6.0.6",
    "style-loader": "^0.19.1"
  }
}
0
0123cf
0
0123cf
commented 6 months ago

How did you solve it?

0
kjfdebruin
0
kjfdebruin
commented 6 months ago

Also having this issue. Any advice @tchret ?

0
xsmartweb
0
xsmartweb
commented 6 months ago

same issue here

0
lintov7
0
lintov7
commented 5 months ago

This happened to me also. I first installed using yarn.
Then installed a dependency using NPM and the error started happening.
Calling yarn fixed this issue for me.

0
Informations
QuestionUnresolved
#c2634 - Created 8 months ago