Can't resolve 'core-js/modules/es7.promise.finally'

gp15237125756
0
gp15237125756
commented 3 months ago

When I execute yarn start after installing dependencies,this error emerge. Also the error file is client.js. I guess babel is mandatory here to resolve the file.So I changed the devDependencies in package.json as below .
"devDependencies": {
"babel-eslint": "^7.2.3",
"babel-core": "6.26.0",
"babel-helper-vue-jsx-merge-props": "^2.0.3",
"babel-loader": "7.1.2",
"babel-plugin-syntax-jsx": "^6.18.0",
"babel-plugin-transform-runtime": "6.23.0",
"babel-plugin-transform-vue-jsx": "^3.5.0",
"babel-polyfill": "^6.26.0",
"babel-preset-env": "^1.6.1",
"babel-preset-stage-2": "6.24.1",
"eslint": "^4.3.0",
"eslint-config-standard": "^10.2.1",
"eslint-loader": "^1.9.0",
"eslint-plugin-html": "^3.1.1",
"eslint-plugin-import": "^2.7.0",
"eslint-plugin-node": "^5.1.1",
"eslint-plugin-promise": "^3.5.0",
"eslint-plugin-standard": "^3.0.1"
}
then the error disappeared.
My environment is windows 7 & node 8.11.1.

0
Informations
Question โ€ข Unresolved
#c117 - Created 3 months ago